summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index e94d5c6c..d3b6e847 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -1,3 +1,6 @@
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/version.h.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/version.h" @ONLY)
+
set(HEADER_FILES
cacep.h
cdefs.h
@@ -8,7 +11,9 @@ set(HEADER_FILES
ipcp.h
irm.h
proto.h
- qos.h)
+ qos.h
+ ${CMAKE_CURRENT_BINARY_DIR}/version.h
+ )
install(FILES ${HEADER_FILES} DESTINATION usr/include/ouroboros)