summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2018-01-10 16:06:18 +0100
committerSander Vrijders <sander.vrijders@ugent.be>2018-01-10 18:38:30 +0100
commitd22606dc078bbd618d2563a552a62cd4f46ac682 (patch)
treef3535e2de293c7f5f8f21ae44d2a0537ee941157 /include/ouroboros/CMakeLists.txt
parentb71c2cc9938eee649d6b4a787d4c4bebe849d6e9 (diff)
downloadouroboros-0.9.0.tar.gz
ouroboros-0.9.0.zip
include: Add version header0.9.0
This moves the version definition for Ouroboros into its own header file, which is generated by CMake and installed on the system. Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index e94d5c6c..d3b6e847 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -1,3 +1,6 @@
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/version.h.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/version.h" @ONLY)
+
set(HEADER_FILES
cacep.h
cdefs.h
@@ -8,7 +11,9 @@ set(HEADER_FILES
ipcp.h
irm.h
proto.h
- qos.h)
+ qos.h
+ ${CMAKE_CURRENT_BINARY_DIR}/version.h
+ )
install(FILES ${HEADER_FILES} DESTINATION usr/include/ouroboros)