summaryrefslogtreecommitdiff
path: root/src/lib/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-08 11:18:47 +0100
committerDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-08 11:18:47 +0100
commit5f249bae0ca8fbdf81aa2ab78ce0f5efc7c35f38 (patch)
treed23d6a0dbbbbe2ccdefef94ab88ebdedd3faacfe /src/lib/tests/CMakeLists.txt
parentf94912a3ea1025c689a5336a1fdc807baa8fa36f (diff)
downloadouroboros-5f249bae0ca8fbdf81aa2ab78ce0f5efc7c35f38.tar.gz
ouroboros-5f249bae0ca8fbdf81aa2ab78ce0f5efc7c35f38.zip
lib: Updated du_buff test
Tests should have "_test.c" appended and include the source they are testing. The build system will find it in the parent directory. Removed linked_list example test as it is now useless.
Diffstat (limited to 'src/lib/tests/CMakeLists.txt')
-rw-r--r--src/lib/tests/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/lib/tests/CMakeLists.txt b/src/lib/tests/CMakeLists.txt
index 5725acc7..b1259fa8 100644
--- a/src/lib/tests/CMakeLists.txt
+++ b/src/lib/tests/CMakeLists.txt
@@ -3,8 +3,7 @@ get_filename_component(src_folder "${tmp}" NAME)
create_test_sourcelist(${src_folder}_tests test_suite.c
# Add new tests here
- linked_list.c
- du_buff.c
+ du_buff_test.c
)
add_executable(${src_folder}_test EXCLUDE_FROM_ALL ${${src_folder}_tests})