summaryrefslogtreecommitdiff
path: root/src/lib/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-08 08:37:35 +0100
committerDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-08 09:25:16 +0100
commitf94912a3ea1025c689a5336a1fdc807baa8fa36f (patch)
tree48e568772f688582f5bfd9fd664c511f0ed9981a /src/lib/tests/CMakeLists.txt
parentaf8db503f46049fabaa793905f35bf0a2867744b (diff)
downloadouroboros-f94912a3ea1025c689a5336a1fdc807baa8fa36f.tar.gz
ouroboros-f94912a3ea1025c689a5336a1fdc807baa8fa36f.zip
tests: added test for the du_buff structure
tests/du_buff.c: tests the du_buff_t structure by creating different size du_buff_t's and filling it with different size sdu's at different locations in the du_buff_t tests/CMakefile.txt: added du_buff test lib/du_buff.c: fixed unsafe #define adding brackets
Diffstat (limited to 'src/lib/tests/CMakeLists.txt')
-rw-r--r--src/lib/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/lib/tests/CMakeLists.txt b/src/lib/tests/CMakeLists.txt
index 2b02768b..5725acc7 100644
--- a/src/lib/tests/CMakeLists.txt
+++ b/src/lib/tests/CMakeLists.txt
@@ -4,6 +4,7 @@ get_filename_component(src_folder "${tmp}" NAME)
create_test_sourcelist(${src_folder}_tests test_suite.c
# Add new tests here
linked_list.c
+ du_buff.c
)
add_executable(${src_folder}_test EXCLUDE_FROM_ALL ${${src_folder}_tests})