summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-29 12:06:58 +0200
committerDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-29 12:06:58 +0200
commit1d4442e472d20f261986089ea468daa93631d1f4 (patch)
tree3b27a134c762190b096de421310a50910dca4a34 /src/lib/CMakeLists.txt
parente5d67f7d4df123c2490201447681f2efd553dcc1 (diff)
parent37c4ccaf59a0406053573e14909be48322ffb084 (diff)
downloadouroboros-1d4442e472d20f261986089ea468daa93631d1f4.tar.gz
ouroboros-1d4442e472d20f261986089ea468daa93631d1f4.zip
Merged in sandervrijders/ouroboros/be-gpb (pull request #45)
Replace custom ser/des with GPB
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt53
1 files changed, 33 insertions, 20 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 42a4d5c0..c986112e 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -4,40 +4,53 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR})
include_directories(${CMAKE_SOURCE_DIR}/include)
include_directories(${CMAKE_BINARY_DIR}/include)
+find_package(ProtobufC REQUIRED)
+include_directories(${PROTOBUF_INCLUDE_DIRS})
+protobuf_generate_c(IRM_PROTO_SRCS IRM_PROTO_HDRS irmd_messages.proto)
+protobuf_generate_c(IPCP_PROTO_SRCS IPCP_PROTO_HDRS ipcpd_messages.proto)
+
find_library(LIBRT_LIBRARIES rt)
if(NOT LIBRT_LIBRARIES)
- message(FATAL_ERROR "librt not found")
+ message(FATAL_ERROR "librt not found")
endif()
find_library(LIBPTHREAD_LIBRARIES pthread)
if(NOT LIBPTHREAD_LIBRARIES)
- message(FATAL_ERROR "libpthread not found")
+ message(FATAL_ERROR "libpthread not found")
endif()
set(SOURCE_FILES
- # Add source files here
- bitmap.c
- cdap.c
- da.c
- dev.c
- du_buff.c
- ipcp.c
- irm.c
- list.c
- rina_name.c
- shm_du_map.c
- sockets.c
- utils.c
-)
-
-add_library(ouroboros SHARED ${SOURCE_FILES})
-target_link_libraries(ouroboros ${LIBRT_LIBRARIES} ${LIBPTHREAD_LIBRARIES})
+ # Add source files here
+ bitmap.c
+ cdap.c
+ da.c
+ dev.c
+ du_buff.c
+ ipcp.c
+ irm.c
+ list.c
+ rina_name.c
+ shm_du_map.c
+ sockets.c
+ utils.c
+ )
+
+install(FILES ${IRM_PROTO_HDRS} ${IPCP_PROTO_HDRS}
+ DESTINATION include/ouroboros)
+
+add_library(ouroboros SHARED ${SOURCE_FILES}
+ ${IRM_PROTO_SRCS} ${IPCP_PROTO_SRCS})
+
+target_link_libraries(ouroboros ${LIBRT_LIBRARIES}
+ ${LIBPTHREAD_LIBRARIES} ${PROTOBUF_C_LIBRARY})
include(MacroAddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)
- MACRO_ADD_COMPILE_FLAGS(ouroboros -DCONFIG_OUROBOROS_DEBUG)
+ MACRO_ADD_COMPILE_FLAGS(ouroboros -DCONFIG_OUROBOROS_DEBUG)
endif (CMAKE_BUILD_TYPE MATCHES Debug)
install(TARGETS ouroboros LIBRARY DESTINATION lib)
+target_include_directories(ouroboros PUBLIC ${CMAKE_CURRENT_BINARY_DIR})
+
add_subdirectory(tests)