summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-28 16:38:56 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-28 16:38:56 +0200
commit37c4ccaf59a0406053573e14909be48322ffb084 (patch)
tree3b27a134c762190b096de421310a50910dca4a34 /src/lib/CMakeLists.txt
parentc45be0dcbd123881cc33ce61571578dcb22c3b54 (diff)
parente5d67f7d4df123c2490201447681f2efd553dcc1 (diff)
downloadouroboros-37c4ccaf59a0406053573e14909be48322ffb084.tar.gz
ouroboros-37c4ccaf59a0406053573e14909be48322ffb084.zip
Merge remote-tracking branch 'upstream/be' into be-gpb
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 52061645..c986112e 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -40,7 +40,9 @@ install(FILES ${IRM_PROTO_HDRS} ${IPCP_PROTO_HDRS}
add_library(ouroboros SHARED ${SOURCE_FILES}
${IRM_PROTO_SRCS} ${IPCP_PROTO_SRCS})
-target_link_libraries(ouroboros rt pthread ${PROTOBUF_C_LIBRARY})
+
+target_link_libraries(ouroboros ${LIBRT_LIBRARIES}
+ ${LIBPTHREAD_LIBRARIES} ${PROTOBUF_C_LIBRARY})
include(MacroAddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)