summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-07-05 15:43:13 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-07-05 15:43:13 +0200
commita315150a16c02f3cb694e639d5aba555fce4b4c3 (patch)
tree59525d68eec0cf5d2dae83891c7bc4eaabff9cf3 /include/ouroboros/CMakeLists.txt
parentaca5db11a73e66377b8566e69c1baabb1df803ab (diff)
downloadouroboros-a315150a16c02f3cb694e639d5aba555fce4b4c3.tar.gz
ouroboros-a315150a16c02f3cb694e639d5aba555fce4b4c3.zip
lib: Provide first implementation of revised CDAP
This commit introduces a first version of the revised CDAP specification. CACEP (for authentication purposes) has been separated from CDAP. Application developers may use CDAP if they find it useful. Within Ouroboros CDAP will be used to perform operations on the RIB of an IPCP.
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index 68c88a18..ee339294 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -3,14 +3,14 @@ configure_file(
"${CMAKE_CURRENT_BINARY_DIR}/config.h")
set(HEADER_FILES
- cdap.h
- dev.h
- errno.h
- flow.h
- irm.h
- irm_config.h
- nsm.h
- qos.h
-)
+ cdap.h
+ common.h
+ dev.h
+ errno.h
+ flow.h
+ irm.h
+ irm_config.h
+ nsm.h
+ qos.h)
install(FILES ${HEADER_FILES} DESTINATION usr/include/ouroboros)