summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2024-02-19 16:05:59 +0100
committerSander Vrijders <sander@ouroboros.rocks>2024-02-19 16:06:34 +0100
commitc58cc09cf50a18058efb59e1b4fb73ab1e3a45a2 (patch)
tree7674e6939fc30eb3b052686ea2ee95bde3580bca /CMakeLists.txt
parentd2556ebc3fbc59736863e53f5b2c35e72eb09ae8 (diff)
downloadouroboros-c58cc09cf50a18058efb59e1b4fb73ab1e3a45a2.tar.gz
ouroboros-c58cc09cf50a18058efb59e1b4fb73ab1e3a45a2.zip
lib: Fix CRC32 hashing0.21.1
I assumed that all hashes were stored in Big Endian, but apparently the CRC32 was still in machine endianness when calculated by the rhash implementation. Fixed and updated hash tests a bit. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc89d2d5..7bed8396 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ include(GNUInstallDirs)
set(PACKAGE_VERSION_MAJOR 0)
set(PACKAGE_VERSION_MINOR 21)
-set(PACKAGE_VERSION_PATCH 0)
+set(PACKAGE_VERSION_PATCH 1)
set(PACKAGE_NAME "${CMAKE_PROJECT_NAME}")
set(PACKAGE_DESCRIPTION "The Ouroboros prototype")