summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@ugent.be>2017-09-13 18:07:24 +0200
committerdimitri staessens <dimitri.staessens@ugent.be>2017-09-13 18:17:07 +0200
commit8c5557af6ff55b0dd806aa5205be7a11e92db990 (patch)
tree963de29dbc93931f9844269e53beea27568736d4 /CMakeLists.txt
parent0ed2ae85935be59b3fee5663a9906c4260cd64cc (diff)
downloadouroboros-8c5557af6ff55b0dd806aa5205be7a11e92db990.tar.gz
ouroboros-8c5557af6ff55b0dd806aa5205be7a11e92db990.zip
build: Clean up output with missing ProtobufC
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 642c391c..624950bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,7 +85,12 @@ endif ()
enable_testing()
add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})
-find_package(ProtobufC REQUIRED QUIET)
+find_package(ProtobufC QUIET)
+if (NOT (PROTOBUF_C_INCLUDE_DIRS AND PROTOBUF_C_LIBRARY
+ AND PROTOBUF_PROTOC_C_EXECUTABLE))
+ message(FATAL_ERROR "Protobuf C compiler required but not found. "
+ "Please install Google Protocol Buffers.")
+endif ()
include_directories(${PROTOBUF_C_INCLUDE_DIRS})
add_subdirectory(include)