aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNick Aerts <nick.aerts@ugent.be>2018-02-24 12:27:36 +0100
committerNick Aerts <nick.aerts@ugent.be>2018-03-20 11:30:07 +0100
commita7cd88d752b72ea85ccefa5e1f3dceba13fb1fc2 (patch)
tree9c29f08693d577c81959c3194aec04e9bc1ba195 /setup.py
parent24bed306b5a67fc682b04cae017b0d0f3ac55a00 (diff)
downloadrumba-a7cd88d752b72ea85ccefa5e1f3dceba13fb1fc2.tar.gz
rumba-a7cd88d752b72ea85ccefa5e1f3dceba13fb1fc2.zip
testbeds: Add docker testbed
This adds support for a testbed based on Docker containers running on the local host. Bridging the containers can be done using built-in Linux bridging or using OpenVSwitch bridges. A new resource 'executor' has been added to abstract away command execution on nodes on the testbed. Executors have been created for local command execution, docker exec based command execution and SSH-based command execution. This has also been changed in the prototypes to execute using the correct executor.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 99ff69c..79b5633 100755
--- a/setup.py
+++ b/setup.py
@@ -12,9 +12,10 @@ setuptools.setup(
author_email='sander.vrijders@ugent.be',
license='LGPL',
description='Rumba measurement framework for RINA',
- packages=['rumba', 'rumba.testbeds', 'rumba.prototypes'],
+ packages=['rumba', 'rumba.testbeds', 'rumba.prototypes', 'rumba.executors'],
install_requires=[
'paramiko',
+ 'docker',
'repoze.lru; python_version<"3.2"',
'contextlib2; python_version<"3.0"',
'enum34; python_version<"3.0"'