summaryrefslogtreecommitdiff
path: root/src/lib/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/lib/tests/CMakeLists.txt')
-rw-r--r--src/lib/tests/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/lib/tests/CMakeLists.txt b/src/lib/tests/CMakeLists.txt
index 99df7232..d4bcb4e4 100644
--- a/src/lib/tests/CMakeLists.txt
+++ b/src/lib/tests/CMakeLists.txt
@@ -1,14 +1,27 @@
get_filename_component(tmp ".." ABSOLUTE)
get_filename_component(src_folder "${tmp}" NAME)
+find_library(LIBRT_LIBRARIES rt)
+if(NOT LIBRT_LIBRARIES)
+ message(FATAL_ERROR "librt not found")
+endif()
+
+find_library(LIBPTHREAD_LIBRARIES pthread)
+if(NOT LIBPTHREAD_LIBRARIES)
+ message(FATAL_ERROR "libpthread not found")
+endif()
+
create_test_sourcelist(${src_folder}_tests test_suite.c
# Add new tests here
bitmap_test.c
du_buff_test.c
+ shm_du_map_test_create.c
+ shm_du_map_test_du_buff_create.c
+ shm_du_map_test_prod_cons.c
)
add_executable(${src_folder}_test EXCLUDE_FROM_ALL ${${src_folder}_tests})
-target_link_libraries(${src_folder}_test ouroboros)
+target_link_libraries(${src_folder}_test ouroboros rt pthread)
add_dependencies(check ${src_folder}_test)