summaryrefslogtreecommitdiff
path: root/src/lib/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-19 13:40:03 +0100
committerDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-19 13:53:52 +0100
commit7712e3ea9fc6772b47f593acbe3088cae01c16d2 (patch)
tree3e0962e8f7bc3957251bbe17ab418c5ebbda555b /src/lib/tests/CMakeLists.txt
parent8d2ac4877bb14df8e10d13b61d5db6c5e11d87c3 (diff)
downloadouroboros-7712e3ea9fc6772b47f593acbe3088cae01c16d2.tar.gz
ouroboros-7712e3ea9fc6772b47f593acbe3088cae01c16d2.zip
lib: shared memory map
The shared memory map will allow passing SDU's between IPCPs efficiently. It is a single block of managed memory. SDU's are stored in a shm_du_buff datastructure, which is a list of blocks inside the shared memory region. The mechanism for passing SDU's is not yet implemented and could be either within the region or using another local IPC mechanism. The following things are configured at compile time: SHM_FILE_NAME : the name. Default is "ouroboros_du_map". SHM_DU_BUFF_BLOCK_SIZE: size of a block inside the shared memory region. Default is the pagesize of the system. SHM_DU_MAP_SIZE : the approximate size in bytes of the shared memory map. The actual filesize may differ by a small margin. Default is 4MB.
Diffstat (limited to 'src/lib/tests/CMakeLists.txt')
-rw-r--r--src/lib/tests/CMakeLists.txt15
1 files changed, 14 insertions, 1 deletions
diff --git a/src/lib/tests/CMakeLists.txt b/src/lib/tests/CMakeLists.txt
index 99df7232..d4bcb4e4 100644
--- a/src/lib/tests/CMakeLists.txt
+++ b/src/lib/tests/CMakeLists.txt
@@ -1,14 +1,27 @@
get_filename_component(tmp ".." ABSOLUTE)
get_filename_component(src_folder "${tmp}" NAME)
+find_library(LIBRT_LIBRARIES rt)
+if(NOT LIBRT_LIBRARIES)
+ message(FATAL_ERROR "librt not found")
+endif()
+
+find_library(LIBPTHREAD_LIBRARIES pthread)
+if(NOT LIBPTHREAD_LIBRARIES)
+ message(FATAL_ERROR "libpthread not found")
+endif()
+
create_test_sourcelist(${src_folder}_tests test_suite.c
# Add new tests here
bitmap_test.c
du_buff_test.c
+ shm_du_map_test_create.c
+ shm_du_map_test_du_buff_create.c
+ shm_du_map_test_prod_cons.c
)
add_executable(${src_folder}_test EXCLUDE_FROM_ALL ${${src_folder}_tests})
-target_link_libraries(${src_folder}_test ouroboros)
+target_link_libraries(${src_folder}_test ouroboros rt pthread)
add_dependencies(check ${src_folder}_test)