summaryrefslogtreecommitdiff
path: root/src/ipcpd/udp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ipcpd/udp/CMakeLists.txt')
-rw-r--r--src/ipcpd/udp/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/ipcpd/udp/CMakeLists.txt b/src/ipcpd/udp/CMakeLists.txt
index b21afe75..f1a29ef6 100644
--- a/src/ipcpd/udp/CMakeLists.txt
+++ b/src/ipcpd/udp/CMakeLists.txt
@@ -16,9 +16,11 @@ set(IPCP_UDP_TARGET ipcpd-udp CACHE INTERNAL "")
set(UDP_SOURCES
# Add source files here
- ${CMAKE_CURRENT_SOURCE_DIR}/main.c)
+ ${CMAKE_CURRENT_SOURCE_DIR}/main.c
+ )
add_executable(ipcpd-udp ${UDP_SOURCES} ${IPCP_SOURCES})
+
target_link_libraries(ipcpd-udp LINK_PUBLIC ouroboros-dev)
# Find the nsupdate executable
@@ -52,6 +54,11 @@ else ()
endif ()
endif ()
+set(IPCP_UDP_RD_THR 3 CACHE STRING
+ "Number of reader threads in UDP IPCP")
+set(IPCP_UDP_WR_THR 3 CACHE STRING
+ "Number of writer threads in UDP IPCP")
+
include(AddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES "Debug*")
add_compile_flags(ipcpd-udp -DCONFIG_OUROBOROS_DEBUG)