summaryrefslogtreecommitdiff
path: root/src/tools/operf/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-10-30 10:53:04 +0100
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-10-30 13:24:19 +0100
commit05fa4879dd8c70156fd98eabed4634098b0feecb (patch)
tree49e677cf3626a58737fd3d2d7ac8b0dd7a74517f /src/tools/operf/CMakeLists.txt
parentc089d9ccc2552c0caee55bfa6c2e6df76e82fe33 (diff)
downloadouroboros-05fa4879dd8c70156fd98eabed4634098b0feecb.tar.gz
ouroboros-05fa4879dd8c70156fd98eabed4634098b0feecb.zip
tools: Add operf tool
This tool allows bidirectional bandwidth measurement between a client and server application. The server reflects all traffic back to the client. The traffic can be capped at a certain rate or set to flood.
Diffstat (limited to 'src/tools/operf/CMakeLists.txt')
-rw-r--r--src/tools/operf/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/tools/operf/CMakeLists.txt b/src/tools/operf/CMakeLists.txt
new file mode 100644
index 00000000..b63d24ee
--- /dev/null
+++ b/src/tools/operf/CMakeLists.txt
@@ -0,0 +1,21 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+find_library(LIBM_LIBRARIES m)
+if(NOT LIBM_LIBRARIES)
+ message(FATAL_ERROR "libm not found")
+endif()
+
+set(SOURCE_FILES
+ # Add source files here
+ operf.c
+)
+
+add_executable(operf ${SOURCE_FILES})
+
+target_link_libraries(operf LINK_PUBLIC ${LIBM_LIBRARIES} ouroboros)
+
+install(TARGETS operf RUNTIME DESTINATION usr/bin)