summaryrefslogtreecommitdiff
path: root/src/tools/irm/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-02 19:43:07 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-02 19:43:07 +0100
commitccbfc46ada3317b0f3655b751d473643d4dcab72 (patch)
tree4f418e7f612a5a717e3351c3c911617537012c51 /src/tools/irm/CMakeLists.txt
parent3bebab119c5a2c59121355c72b4e69b2817eea3a (diff)
downloadouroboros-ccbfc46ada3317b0f3655b751d473643d4dcab72.tar.gz
ouroboros-ccbfc46ada3317b0f3655b751d473643d4dcab72.zip
tools: irm: Parse arguments for irm and create_ipcp
This parses the arguments passed to irm at the top level, and also the arguments supplied when calling irm create_ipcp. It subsequently calls irm_create_ipcp with these arguments.
Diffstat (limited to 'src/tools/irm/CMakeLists.txt')
-rw-r--r--src/tools/irm/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/tools/irm/CMakeLists.txt b/src/tools/irm/CMakeLists.txt
index 82c73e38..b0d2697b 100644
--- a/src/tools/irm/CMakeLists.txt
+++ b/src/tools/irm/CMakeLists.txt
@@ -6,7 +6,14 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(SOURCE_FILES
# Add source files here
- main.c
+ irm.c
+ irm_create_ipcp.c
+ irm_destroy_ipcp.c
+ irm_bootstrap_ipcp.c
+ irm_enroll_ipcp.c
+ irm_register_ipcp.c
+ irm_unregister_ipcp.c
+ irm_utils.c
)
add_executable (irm ${SOURCE_FILES})