summaryrefslogtreecommitdiff
path: root/src/tools/irm/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2020-03-08 13:29:21 +0100
committerSander Vrijders <sander@ouroboros.rocks>2020-03-15 14:20:38 +0100
commitc80c93f11dbfb1b0c07f9a6f8b8d91024e5db507 (patch)
treec6ac06aa8841bcb4a403507deda4401594d5cdbe /src/tools/irm/CMakeLists.txt
parent8796a612f0600fc973aa908b84ded837f3470512 (diff)
downloadouroboros-c80c93f11dbfb1b0c07f9a6f8b8d91024e5db507.tar.gz
ouroboros-c80c93f11dbfb1b0c07f9a6f8b8d91024e5db507.zip
irm: Revise naming API
This revises the naming API to treat names (or reg_name in the source) as first-class citizens of the architecture. This is more in line with the way they are described in the article. Operations have been added to create/destroy names independently of registering. This was previously done only as part of register, and there was no way to delete a name from the IRMd. The create call now allows specifying a policy for load-balancing incoming flows for a name. The default is the new round-robin load-balancer, the previous behaviour is still available as a spillover load-balancer. The register calls will still create a name if it doesn't exist, with the default round-robin load-balancer. The tools now have a "name" section, so the format is now irm name <operation> <name> ... Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/tools/irm/CMakeLists.txt')
-rw-r--r--src/tools/irm/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/tools/irm/CMakeLists.txt b/src/tools/irm/CMakeLists.txt
index ca32e9c7..e5e5c466 100644
--- a/src/tools/irm/CMakeLists.txt
+++ b/src/tools/irm/CMakeLists.txt
@@ -23,8 +23,12 @@ set(SOURCE_FILES
irm_unbind.c
irm_bind.c
irm_ipcp.c
- irm_register.c
- irm_unregister.c
+ irm_name.c
+ irm_name_create.c
+ irm_name_destroy.c
+ irm_name_reg.c
+ irm_name_unreg.c
+ irm_name_list.c
irm_utils.c
)