summaryrefslogtreecommitdiff
path: root/src/tools/irm/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-06-28 16:11:19 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-06-28 16:22:01 +0200
commit0d789ed8d938cc342c8f2138280795a1d5a61e3d (patch)
treeb0a3b305473a68ee18262e7f103185b9ce9cb98c /src/tools/irm/CMakeLists.txt
parentacd29da104d0d8ddace2b2693314542bb5a56fcc (diff)
downloadouroboros-0d789ed8d938cc342c8f2138280795a1d5a61e3d.tar.gz
ouroboros-0d789ed8d938cc342c8f2138280795a1d5a61e3d.zip
lib, irmd, ipcpd: Change of IRM API
This changes the IRM API after discussions with Dimitri. The register operation is now split into a bind and register operation. The same for unregister; unbind and unregister. PIDs are now used as the application instance name. A name for a PID is only provided for scriptability in bash. It is therefore also no longer passed down to the IPCP. Every operation on an IPCP through the IRM API has to use the PID. Quering of the PIDs by name is possible. The IRM tool has been updated to use this new API as well. A subcommand 'ipcp' has been added for operations that take effect on IPCPs only. Fixes #12
Diffstat (limited to 'src/tools/irm/CMakeLists.txt')
-rw-r--r--src/tools/irm/CMakeLists.txt11
1 files changed, 7 insertions, 4 deletions
diff --git a/src/tools/irm/CMakeLists.txt b/src/tools/irm/CMakeLists.txt
index d1f227a8..68297615 100644
--- a/src/tools/irm/CMakeLists.txt
+++ b/src/tools/irm/CMakeLists.txt
@@ -7,10 +7,13 @@ include_directories(${CMAKE_BINARY_DIR}/include)
set(SOURCE_FILES
# Add source files here
irm.c
- irm_create_ipcp.c
- irm_destroy_ipcp.c
- irm_bootstrap_ipcp.c
- irm_enroll_ipcp.c
+ irm_ipcp_create.c
+ irm_ipcp_destroy.c
+ irm_ipcp_bootstrap.c
+ irm_ipcp_enroll.c
+ irm_unbind.c
+ irm_bind.c
+ irm_ipcp.c
irm_register.c
irm_unregister.c
irm_utils.c