summaryrefslogtreecommitdiff
path: root/src/lib/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-07 15:13:34 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-07 15:13:34 +0100
commitf9c16675dc625c124345bb440aa9604af61ddb8d (patch)
treeada38ded21f6e7e2a93f7047ee78bcc309da1011 /src/lib/tests/CMakeLists.txt
parent486b601ecb6d79c90eadc4dda0981e25e6a7ba1d (diff)
downloadouroboros-f9c16675dc625c124345bb440aa9604af61ddb8d.tar.gz
ouroboros-f9c16675dc625c124345bb440aa9604af61ddb8d.zip
build: Add check target, fix packaging
This adds a build target 'check', which executes a test suite for every daemon/library. Every test suite consists of a test driver that executes a function in a file with the same name as the function. The compile_debug script executes the 'check' target to validate there are no regressions. Packaging is also fixed and the prototype can be shipped as a tarball.
Diffstat (limited to 'src/lib/tests/CMakeLists.txt')
-rw-r--r--src/lib/tests/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/lib/tests/CMakeLists.txt b/src/lib/tests/CMakeLists.txt
new file mode 100644
index 00000000..2b02768b
--- /dev/null
+++ b/src/lib/tests/CMakeLists.txt
@@ -0,0 +1,20 @@
+get_filename_component(tmp ".." ABSOLUTE)
+get_filename_component(src_folder "${tmp}" NAME)
+
+create_test_sourcelist(${src_folder}_tests test_suite.c
+ # Add new tests here
+ linked_list.c
+)
+
+add_executable(${src_folder}_test EXCLUDE_FROM_ALL ${${src_folder}_tests})
+target_link_libraries(${src_folder}_test ouroboros)
+
+add_dependencies(check ${src_folder}_test)
+
+set(tests_to_run ${${src_folder}_tests})
+remove(tests_to_run test_suite.c)
+
+foreach(test ${tests_to_run})
+ get_filename_component(test_name ${test} NAME_WE)
+ add_test(${test_name} ${C_TEST_PATH}/${src_folder}_test ${test_name})
+endforeach(test)