summaryrefslogtreecommitdiff
path: root/src/lib/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2019-06-20 22:00:34 +0200
committerSander Vrijders <sander@ouroboros.rocks>2019-06-21 18:47:30 +0200
commitdc6be97bccd86cfbd64586a5fd9faefb673b70a6 (patch)
tree3b09335a529d099e82fd661a06dfc566b8b905a6 /src/lib/tests/CMakeLists.txt
parent6a81bd8a4df688f397a8b218f326f4e5ce71f6cd (diff)
downloadouroboros-dc6be97bccd86cfbd64586a5fd9faefb673b70a6.tar.gz
ouroboros-dc6be97bccd86cfbd64586a5fd9faefb673b70a6.zip
lib: Add tests for the shm_rbuff
This adds some tests for the shm_rbuff after some reports that the queue length would be erroneously reported as 0 when the rbuff was full. The test passes for the reported case. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/lib/tests/CMakeLists.txt')
-rw-r--r--src/lib/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/lib/tests/CMakeLists.txt b/src/lib/tests/CMakeLists.txt
index cc51c203..c887626a 100644
--- a/src/lib/tests/CMakeLists.txt
+++ b/src/lib/tests/CMakeLists.txt
@@ -9,6 +9,7 @@ create_test_sourcelist(${PARENT_DIR}_tests test_suite.c
hashtable_test.c
md5_test.c
sha3_test.c
+ shm_rbuff_test.c
time_utils_test.c
)