summaryrefslogtreecommitdiff
path: root/src/lib/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-12-21 14:29:31 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-12-21 14:54:29 +0100
commitb814df8ed2939649284533d61eb26c29ed2ab2c8 (patch)
tree940558479b10f3cb73216b76de31b21f85410854 /src/lib/tests/CMakeLists.txt
parentfc8d30f2d6e9f3e463aff81a1630ff56f9463a22 (diff)
downloadouroboros-b814df8ed2939649284533d61eb26c29ed2ab2c8.tar.gz
ouroboros-b814df8ed2939649284533d61eb26c29ed2ab2c8.zip
lib, ipcpd: Add hashtable and PDU Forwarding Function
This adds a hash table that takes 64-bit integers as key and uses separate chaining on collision. It also adds the PDU Forwarding Function, which the Flow Manager can use to lookup the fd towards the next hop. Routing policies will add/update/remove entries in the PFF.
Diffstat (limited to 'src/lib/tests/CMakeLists.txt')
-rw-r--r--src/lib/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/lib/tests/CMakeLists.txt b/src/lib/tests/CMakeLists.txt
index 2135cb95..64671934 100644
--- a/src/lib/tests/CMakeLists.txt
+++ b/src/lib/tests/CMakeLists.txt
@@ -4,6 +4,7 @@ get_filename_component(PARENT_DIR ${PARENT_PATH} NAME)
create_test_sourcelist(${PARENT_DIR}_tests test_suite.c
# Add new tests here
bitmap_test.c
+ hashtable_test.c
)
add_executable(${PARENT_DIR}_test EXCLUDE_FROM_ALL ${${PARENT_DIR}_tests})