summaryrefslogtreecommitdiff
path: root/src/lib/tests/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-03-24 20:51:55 +0100
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-03-24 20:51:55 +0100
commit0dd4526f5c75f23aba886bee2d9850a70aa67ca8 (patch)
tree3480b39405a9ce935a5d110ebfacc121f9440b37 /src/lib/tests/CMakeLists.txt
parent545092a8eaa1a972a2bcaf1b532d74f21db1b623 (diff)
downloadouroboros-0dd4526f5c75f23aba886bee2d9850a70aa67ca8.tar.gz
ouroboros-0dd4526f5c75f23aba886bee2d9850a70aa67ca8.zip
lib: Shared Memory
Updated tests. Added code to drop a corner case (packet where the tail PCI would cross the edge of the ring buffer) because solving this very rare case is not worth the performance hit on the ringbuffer the extra code would incur. This means the ringbuffer might drop a very small percentage of packets.
Diffstat (limited to 'src/lib/tests/CMakeLists.txt')
-rw-r--r--src/lib/tests/CMakeLists.txt16
1 files changed, 2 insertions, 14 deletions
diff --git a/src/lib/tests/CMakeLists.txt b/src/lib/tests/CMakeLists.txt
index d4bcb4e4..80834df8 100644
--- a/src/lib/tests/CMakeLists.txt
+++ b/src/lib/tests/CMakeLists.txt
@@ -1,27 +1,15 @@
get_filename_component(tmp ".." ABSOLUTE)
get_filename_component(src_folder "${tmp}" NAME)
-find_library(LIBRT_LIBRARIES rt)
-if(NOT LIBRT_LIBRARIES)
- message(FATAL_ERROR "librt not found")
-endif()
-
-find_library(LIBPTHREAD_LIBRARIES pthread)
-if(NOT LIBPTHREAD_LIBRARIES)
- message(FATAL_ERROR "libpthread not found")
-endif()
-
create_test_sourcelist(${src_folder}_tests test_suite.c
# Add new tests here
bitmap_test.c
du_buff_test.c
- shm_du_map_test_create.c
- shm_du_map_test_du_buff_create.c
- shm_du_map_test_prod_cons.c
+ shm_du_map_test.c
)
add_executable(${src_folder}_test EXCLUDE_FROM_ALL ${${src_folder}_tests})
-target_link_libraries(${src_folder}_test ouroboros rt pthread)
+target_link_libraries(${src_folder}_test ouroboros)
add_dependencies(check ${src_folder}_test)