summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2022-03-19 21:47:01 +0100
committerSander Vrijders <sander@ouroboros.rocks>2022-03-30 14:55:13 +0200
commitb248af5ee14b6910c6b21a29fb8ebe2126a8f68e (patch)
tree1d20f78ca078c36362f8178b0da501a479f9d268 /src/lib/CMakeLists.txt
parentda6d63bd3a17e681c6f62c74ffe09abe74595c1e (diff)
downloadouroboros-b248af5ee14b6910c6b21a29fb8ebe2126a8f68e.tar.gz
ouroboros-b248af5ee14b6910c6b21a29fb8ebe2126a8f68e.zip
lib: Non-configurable delayed acks in FRCP
It doesn't really make sense to manually and one-sidedly configure the timeout of delayed acknowledgements, as setting it too high upsets the peer's sRTT estimates. Even worse, it also causes a lot of spurious retransmissions if it exceeds the sRTT mean deviation calculated by the receiver. Compensating on bare acknowledgment for the ack delay could improve the RTT estimate deviation, but not the spurious retransmissions if it was set too high. This sets the delayed ack to wait for a single RTT mean deviation. Probably needs more tweaking to further reduce differences between the RTT estimates at the sender and receiver, e.g. compensate the RTT estimate for delayed acks, or increase the RTO to add 8 mdevs to sRTT instead of 4. However, it looks like the mdev estimate is the trickiest one to get to sync, not the RTT average. Linux reduces the sample weight for mdev from 1/4 to 1/32 in some cases, will give that a shot some day too to see if that further align sRTT estimates. In any case, this patch already improves things a lot. Also fixes a bug where the sender was sending acknowlegments on the first packets in flight for the 0 sequence number. The receiver activity was measured in seconds but compared to a timeout value in nanoseconds. There's still a lot of spurious retransmissions that start after actual packet loss occurs, I'm still investigating what causes it. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 022c5cca..0c327320 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -192,8 +192,6 @@ set(DELTA_T_ACK 10 CACHE STRING
"Maximum time to acknowledge a packet (s)")
set(DELTA_T_RTX 120 CACHE STRING
"Maximum time to retransmit a packet (s)")
-set(DELTA_T_ACK_DELAY 10 CACHE STRING
- "Maximum time to wait before acknowledging a packet (ms)")
set(FRCT_REORDER_QUEUE_SIZE 256 CACHE STRING
"Size of the reordering queue, must be a power of 2")
set(FRCT_START_WINDOW 64 CACHE STRING
@@ -214,9 +212,9 @@ set(RXM_WHEEL_LEVELS 3 CACHE STRING
"Number of levels in the retransmission wheel")
set(RXM_WHEEL_SLOTS_PER_LEVEL 256 CACHE STRING
"Number of slots per level in the retransmission wheel, must be a power of 2")
-set(ACK_WHEEL_SLOTS 128 CACHE STRING
+set(ACK_WHEEL_SLOTS 256 CACHE STRING
"Number of slots in the acknowledgment wheel, must be a power of 2")
-set(ACK_WHEEL_RESOLUTION 20 CACHE STRING
+set(ACK_WHEEL_RESOLUTION 18 CACHE STRING
"Minimum acknowledgment delay (ns), as a power to 2")
if (HAVE_FUSE)