summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-28 14:43:16 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-28 14:43:16 +0200
commita14d696bdbc72754e8019fa9579d5a338cc85a05 (patch)
tree2533a574e03a9954b9eeaf7750219d3175ce8b99 /src/lib/CMakeLists.txt
parentd37add0f20c93432c0b4c12866810c124a7a18ec (diff)
downloadouroboros-a14d696bdbc72754e8019fa9579d5a338cc85a05.tar.gz
ouroboros-a14d696bdbc72754e8019fa9579d5a338cc85a05.zip
lib: Update irm.h API
Removes rina_name_t from that API. Passing ap_name and api_id as params instead. The IRM tool has been updated accordingly. Some errors in the build related to protobuf-c have also been resolved.
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index e05dce8b..0427e236 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -34,10 +34,13 @@ set(SOURCE_FILES
shm_du_map.c
sockets.c
utils.c
-)
+ )
-add_library(ouroboros SHARED ${SOURCE_FILES} ${PROTO_SRCS} ${PROTO_HDRS})
-target_link_libraries(ouroboros rt pthread ${PROTOBUF_LIBRARIES})
+install(FILES ${PROTO_HDRS}
+ DESTINATION include/ouroboros)
+
+add_library(ouroboros SHARED ${SOURCE_FILES} ${PROTO_SRCS})
+target_link_libraries(ouroboros rt pthread ${PROTOBUF_C_LIBRARY})
include(MacroAddCompileFlags)
if (CMAKE_BUILD_TYPE MATCHES Debug)
@@ -46,4 +49,6 @@ endif (CMAKE_BUILD_TYPE MATCHES Debug)
install(TARGETS ouroboros LIBRARY DESTINATION lib)
+target_include_directories(ouroboros PUBLIC ${CMAKE_CURRENT_BINARY_DIR})
+
add_subdirectory(tests)