summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@ugent.be>2017-10-12 18:12:05 +0200
committerdimitri staessens <dimitri.staessens@ugent.be>2017-10-13 10:03:47 +0200
commit7a98128e053ccd59203757982f7332ed5e4568ea (patch)
tree8933b54692dabb4f8713d3e0f1689b49a1fae0ea /src/lib/CMakeLists.txt
parent281eaf854247703ed36725ab9dbef3a11d860c5c (diff)
downloadouroboros-7a98128e053ccd59203757982f7332ed5e4568ea.tar.gz
ouroboros-7a98128e053ccd59203757982f7332ed5e4568ea.zip
lib: Re-enable multi-block support
Multi-block support was forgotten during the update of the build system. This enables it again and fixes some bugs when it is disabled and larger SDUs are sent.
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 6ab5ebc8..00670f65 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -165,6 +165,8 @@ set(SHM_RDRB_NAME "/${SHM_PREFIX}.rdrb" CACHE INTERNAL
"Name for the main POSIX shared memory buffer")
set(SHM_RDRB_BLOCK_SIZE "sysconf(_SC_PAGESIZE)" CACHE STRING
"SDU buffer block size, multiple of pagesize for performance")
+set(SHM_RDRB_MULTI_BLOCK true CACHE BOOL
+ "SDU buffer multiblock SDU support")
set(SHM_RBUFF_LOCKLESS 0 CACHE BOOL
"Enable shared memory lockless rbuff support")