summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-08-22 17:38:44 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2017-08-22 17:38:44 +0200
commit743c2f69744fe3f0dac11e467a92ff5e4d80280b (patch)
tree5cd831f6a777d9be5d14e8aff1a66897d8163e19 /src/lib/CMakeLists.txt
parentfb771c0cf876ad58c50551b90dacc0b5689dae05 (diff)
downloadouroboros-743c2f69744fe3f0dac11e467a92ff5e4d80280b.tar.gz
ouroboros-743c2f69744fe3f0dac11e467a92ff5e4d80280b.zip
lib: Fix CRC check and add frct_clear
This adds the CRC check by default on outgoing SDUs. It fixes some errors in the serialization and deserialization of the SDU. frct_clear was added to avoid bad initialization of the array of FRCT instances.
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 4522613b..9d8fbf9c 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -123,7 +123,7 @@ set(AP_MAX_FQUEUES 32 CACHE STRING
"Maximum number of flow sets per application")
set(DU_BUFF_HEADSPACE 128 CACHE STRING
"Bytes of headspace to reserve for future headers")
-set(DU_BUFF_TAILSPACE 0 CACHE STRING
+set(DU_BUFF_TAILSPACE 16 CACHE STRING
"Bytes of tailspace to reserve for future tails")
if (NOT APPLE)
set(PTHREAD_COND_CLOCK "CLOCK_MONOTONIC" CACHE STRING