summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2020-11-23 20:01:19 +0100
committerSander Vrijders <sander@ouroboros.rocks>2020-11-25 15:35:27 +0100
commit4194300ec0af4e268bdb722ba13266352408009c (patch)
treef4b59c1a7dc914008de39543109d4c4cd9059a31 /src/lib/CMakeLists.txt
parent4c01338e4fb8aee6b28603e7e5f7459f59db9561 (diff)
downloadouroboros-4194300ec0af4e268bdb722ba13266352408009c.tar.gz
ouroboros-4194300ec0af4e268bdb722ba13266352408009c.zip
lib: Reduce timerwheel CPU consumption
The timerwheel is checked during IPC calls (fevent, flow_read), causing huge load on CPU consumption in IPCPs, since they have a lot of fevent() threads for QoS. The timerwheel will need further optimization), but for now I reduced the default tick time to 5 ms and added a boolean to check that the wheel is actually used. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index e6d175d3..76d0530d 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -200,7 +200,7 @@ set(FRCT_START_WINDOW 64 CACHE STRING
"Start window, must be a power of 2")
set(FRCT_RTO_MIN 250 CACHE STRING
"Minimum Retransmission Timeout (RTO) for FRCT (us)")
-set(FRCT_TICK_TIME 500 CACHE STRING
+set(FRCT_TICK_TIME 5000 CACHE STRING
"Tick time for FRCT activity (retransmission, acknowledgments) (us)")
set(RXM_BUFFER_ON_HEAP FALSE CACHE BOOL
"Store packets for retransmission on the heap instead of in packet buffer")