summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2023-08-27 17:59:20 +0200
committerSander Vrijders <sander@ouroboros.rocks>2023-08-30 17:11:41 +0200
commit3a321cc77e0f6d29167a925dd706fc36e5aa7cdd (patch)
tree38354765060ed72d98b70e084edcfd061271d018 /src/lib/CMakeLists.txt
parent08332eefba9aa4b08d00e190720de4771081e855 (diff)
downloadouroboros-3a321cc77e0f6d29167a925dd706fc36e5aa7cdd.tar.gz
ouroboros-3a321cc77e0f6d29167a925dd706fc36e5aa7cdd.zip
lib: Move protobuf definitions to pb/ directory
This moves the protobuf definition in the library to a pb/ directory. Also renames the protobuf files and does a quick review of the #define guards in the include library to specify _LIB_ for internal/non-public library headers. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index ac5367ab..b75fd0e0 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -5,17 +5,17 @@ include_directories(${CMAKE_SOURCE_DIR}/include)
include_directories(${CMAKE_BINARY_DIR}/include)
protobuf_generate_c(QOSSPEC_PROTO_SRCS QOSSPEC_PROTO_HDRS
- qosspec.proto)
+ pb/qos.proto)
protobuf_generate_c(IPCP_CONFIG_PROTO_SRCS IPCP_CONFIG_PROTO_HDRS
- ipcp_config.proto)
+ pb/ipcp_config.proto)
protobuf_generate_c(ENROLL_PROTO_SRCS ENROLL_PROTO_HDRS
- enroll.proto)
+ pb/enroll.proto)
protobuf_generate_c(CACEP_PROTO_SRCS CACEP_PROTO_HDRS
- cacep.proto)
+ pb/cacep.proto)
protobuf_generate_c(IRM_PROTO_SRCS IRM_PROTO_HDRS
- irmd_messages.proto)
+ pb/irm.proto)
protobuf_generate_c(IPCP_PROTO_SRCS IPCP_PROTO_HDRS
- ipcpd_messages.proto)
+ pb/ipcp.proto)
if (NOT APPLE)
find_library(LIBRT_LIBRARIES rt)