summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2017-11-08 19:25:48 +0100
committerSander Vrijders <sander.vrijders@ugent.be>2017-11-08 21:40:28 +0100
commit35c43358a110758090b48dd18628bb285ffddfc6 (patch)
tree9746475ac579e516e86f720a3bcb107bf6e36784 /src/lib/CMakeLists.txt
parentc59053040ce927f2926e5a569b19bdd129c354a7 (diff)
downloadouroboros-35c43358a110758090b48dd18628bb285ffddfc6.tar.gz
ouroboros-35c43358a110758090b48dd18628bb285ffddfc6.zip
lib: Use packed struct for FRCT header access
This replaces the variable FRCT header with a packed struct, which significantly simplifies the implementation. The shm_du_buff calls to release the head/tail are updated to return a pointer to the original head or the new tail (in symmetry to the alloc calls, which return a pointer to the new head and old tail), so that it immediately points to the structure that is needed. The frct_pci sources are removed and frct is now fully in the frct.c source file. Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index ba670acf..3531ac27 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -174,7 +174,6 @@ set(SOURCE_FILES_DEV
# Add source files here
cacep.c
dev.c
- frct_pci.c
timerwheel.c
)