summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2020-10-10 15:34:25 +0200
committerSander Vrijders <sander@ouroboros.rocks>2020-10-11 14:23:44 +0200
commit21dec0f30da7eecf965a3b088c9646029354b431 (patch)
treeb83883f2d0d1c4ec20390a8120ec79cc7c0cfcc1 /src/lib/CMakeLists.txt
parentbf736bebbe89618e23fc5cfb19cf049314cce03d (diff)
downloadouroboros-21dec0f30da7eecf965a3b088c9646029354b431.tar.gz
ouroboros-21dec0f30da7eecf965a3b088c9646029354b431.zip
lib: Send and receive window updates
This adds sending and receiving window updates for flow control. I used the 8 pad bits as part of the window update field, so it's 24 bits, allowing for ~16 million packets in flight. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 5e60e375..02fca2d9 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -196,6 +196,8 @@ set(DELTA_T_ACK_DELAY 10 CACHE STRING
"Maximum time to wait before acknowledging a packet (ms)")
set(FRCT_REORDER_QUEUE_SIZE 256 CACHE STRING
"Size of the reordering queue, must be a power of 2")
+set(FRCT_START_WINDOW 64 CACHE STRING
+ "Start window, must be a power of 2")
set(FRCT_RTO_MIN 250 CACHE STRING
"Minimum Retransmission Timeout (RTO) for FRCT (us)")
set(FRCT_TICK_TIME 500 CACHE STRING