summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@ugent.be>2017-09-13 17:00:55 +0200
committerdimitri staessens <dimitri.staessens@ugent.be>2017-09-13 17:22:28 +0200
commit0ed2ae85935be59b3fee5663a9906c4260cd64cc (patch)
treebddca1ad5b5a08ad6fb0a9ec096984e42afe0d38 /src/lib/CMakeLists.txt
parent888d3dbe7c3844d2efe9d6bc9823630db5d47a3b (diff)
downloadouroboros-0ed2ae85935be59b3fee5663a9906c4260cd64cc.tar.gz
ouroboros-0ed2ae85935be59b3fee5663a9906c4260cd64cc.zip
build: Fix DDNS tool detection for shim-udp
This fixes output when detecting DDNS tools and homogenizes output and the APIs used to pass variables between the build system and the sources. Fixes some minor issues and typos).
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index f126a52a..5a09c52e 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -41,7 +41,7 @@ if (HAVE_ROBUST_MUTEX)
endif ()
endif ()
-find_library(LIBGCRYPT_LIBRARIES gcrypt)
+find_library(LIBGCRYPT_LIBRARIES gcrypt QUIET)
if (LIBGCRYPT_LIBRARIES)
find_path(LIBGCRYPT_INCLUDE_DIR gcrypt.h
HINTS /usr/include /usr/local/include)
@@ -50,18 +50,17 @@ if (LIBGCRYPT_LIBRARIES)
REGEX "^#define GCRYPT_VERSION ")
string(REGEX REPLACE "^#define GCRYPT_VERSION \"(.*)\".*$" "\\1"
GCVER "${GCSTR}")
- message(STATUS "Found libgcrypt: ${LIBGCRYPT_LIBRARIES} "
- "(found version \"${GCVER}\")")
if (NOT GCVER VERSION_LESS "1.7.0")
set (DISABLE_LIBGCRYPT FALSE CACHE BOOL "Disable libgcrypt support")
if (NOT DISABLE_LIBGCRYPT)
message(STATUS "libgcrypt support enabled")
set(HAVE_LIBGCRYPT TRUE)
else ()
- message(STATUS "libgcrpyt support disabled by user")
+ message(STATUS "libgcrypt support disabled by user")
endif()
else ()
- message(STATUS "Install version > \"1.7.0\" to enable libgcrypt support")
+ message(STATUS "Install version > \"1.7.0\" to enable libgcrypt support "
+ "(found version \"${GCVER})\"")
endif()
endif ()
endif ()
@@ -71,7 +70,7 @@ if (NOT HAVE_LIBGCRYPT)
set(LIBGCRYPT_INCLUDE_DIR "")
endif ()
-find_package(OpenSSL)
+find_package(OpenSSL QUIET)
if (OPENSSL_FOUND)
set (DISABLE_OPENSSL FALSE CACHE BOOL "Disable OpenSSL support")
if (NOT DISABLE_OPENSSL)