summaryrefslogtreecommitdiff
path: root/src/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2020-04-30 21:21:36 +0200
committerSander Vrijders <sander@ouroboros.rocks>2020-05-01 10:13:10 +0200
commit04b5a939c6a29cdbc733b1113ee8baf400b601bb (patch)
treeaa752b9d9f75923dd59ea01430dd17d970fcd2e5 /src/lib/CMakeLists.txt
parent978266fe4beba21292daad2d341fe5ff22e08aba (diff)
downloadouroboros-04b5a939c6a29cdbc733b1113ee8baf400b601bb.tar.gz
ouroboros-04b5a939c6a29cdbc733b1113ee8baf400b601bb.zip
lib: Fix updating retransmission wheel
Fixes infinite rescheduling with RTO getting lower than the timerwheel resolution. For very low RTO values we'd need a big packet buffer with the current memory allocator implementation (rdrbuff). Setting a (configurable) minimum RTO (250 us) reduces this need. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/lib/CMakeLists.txt')
-rw-r--r--src/lib/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index c5be9946..4aad3a11 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -186,6 +186,8 @@ set(SHM_RBUFF_LOCKLESS 0 CACHE BOOL
"Enable shared memory lockless rbuff support")
set(QOS_DISABLE_CRC TRUE CACHE BOOL
"Ignores ber setting on all QoS cubes")
+set(FRCT_RTO_MIN 250 CACHE STRING
+ "Minimum Retransmission Timeout (RTO) for FRCT (us)")
set(SOURCE_FILES_DEV
# Add source files here