summaryrefslogtreecommitdiff
path: root/src/irmd/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2018-10-18 19:53:24 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2018-10-18 20:08:20 +0200
commit0dbfdabb2f6c3ad907421f90f90714315959339f (patch)
treee406de82e92fb4e53693ce30bf54f57a36e6c86e /src/irmd/CMakeLists.txt
parent8b457e304186c8512139018fcdebc1c221d22ef0 (diff)
downloadouroboros-0dbfdabb2f6c3ad907421f90f90714315959339f.tar.gz
ouroboros-0dbfdabb2f6c3ad907421f90f90714315959339f.zip
ipcpd, irmd: Handle signal in main thread
The signals are now handled in the main thread instead of an asynchronous signal handler. The acceptloop is now correctly cancelled and the associated timeouts are removed. Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'src/irmd/CMakeLists.txt')
-rw-r--r--src/irmd/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/irmd/CMakeLists.txt b/src/irmd/CMakeLists.txt
index 458e1efa..59d0d103 100644
--- a/src/irmd/CMakeLists.txt
+++ b/src/irmd/CMakeLists.txt
@@ -4,8 +4,6 @@ include_directories(${CMAKE_CURRENT_BINARY_DIR})
include_directories(${CMAKE_SOURCE_DIR}/include)
include_directories(${CMAKE_BINARY_DIR}/include)
-set(IRMD_ACCEPT_TIMEOUT 100 CACHE STRING
- "Timeout for accept in IRMD mainloop threads (ms)")
set(IRMD_REQ_ARR_TIMEOUT 500 CACHE STRING
"Timeout for an application to respond to a new flow (ms)")
set(IRMD_FLOW_TIMEOUT 5000 CACHE STRING