summaryrefslogtreecommitdiff
path: root/src/ipcpd/unicast/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2020-02-12 22:31:17 +0100
committerSander Vrijders <sander@ouroboros.rocks>2020-02-16 18:19:59 +0100
commit71eeedd1a05d5dd200c77527ea15086bf43e1a26 (patch)
treede384011e90f0048f47c0a1b932f028dbff34bc5 /src/ipcpd/unicast/CMakeLists.txt
parenta63edb8e9d3ba5eef03c1bbb454522ea7b369087 (diff)
downloadouroboros-71eeedd1a05d5dd200c77527ea15086bf43e1a26.tar.gz
ouroboros-71eeedd1a05d5dd200c77527ea15086bf43e1a26.zip
lib: Move hashtable from lib to unicast
The hashtable is only used for forwarding tables in the unicast IPCP. This moves the generic hashtable out of the library into the unicast IPCP to prepare a more tailored implementation specific to routing tables containing address lists. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/ipcpd/unicast/CMakeLists.txt')
-rw-r--r--src/ipcpd/unicast/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipcpd/unicast/CMakeLists.txt b/src/ipcpd/unicast/CMakeLists.txt
index c9344f89..192b6592 100644
--- a/src/ipcpd/unicast/CMakeLists.txt
+++ b/src/ipcpd/unicast/CMakeLists.txt
@@ -44,6 +44,7 @@ set(SOURCE_FILES
routing.c
psched.c
# Add policies last
+ pol/hashtable.c
pol/alternate_pff.c
pol/flat.c
pol/link_state.c