summaryrefslogtreecommitdiff
path: root/src/ipcpd/unicast/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2023-08-27 17:59:20 +0200
committerSander Vrijders <sander@ouroboros.rocks>2023-08-30 17:11:41 +0200
commit3a321cc77e0f6d29167a925dd706fc36e5aa7cdd (patch)
tree38354765060ed72d98b70e084edcfd061271d018 /src/ipcpd/unicast/CMakeLists.txt
parent08332eefba9aa4b08d00e190720de4771081e855 (diff)
downloadouroboros-3a321cc77e0f6d29167a925dd706fc36e5aa7cdd.tar.gz
ouroboros-3a321cc77e0f6d29167a925dd706fc36e5aa7cdd.zip
lib: Move protobuf definitions to pb/ directory
This moves the protobuf definition in the library to a pb/ directory. Also renames the protobuf files and does a quick review of the #define guards in the include library to specify _LIB_ for internal/non-public library headers. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/ipcpd/unicast/CMakeLists.txt')
-rw-r--r--src/ipcpd/unicast/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/ipcpd/unicast/CMakeLists.txt b/src/ipcpd/unicast/CMakeLists.txt
index c87a58c4..ca742871 100644
--- a/src/ipcpd/unicast/CMakeLists.txt
+++ b/src/ipcpd/unicast/CMakeLists.txt
@@ -16,7 +16,7 @@ set(IPCP_UNICAST_TARGET ipcpd-unicast CACHE INTERNAL "")
set(IPCP_UNICAST_MPL 60 CACHE STRING
"Default maximum packet lifetime for the unicast IPCP, in seconds")
-protobuf_generate_c(KAD_PROTO_SRCS KAD_PROTO_HDRS dir/kademlia.proto)
+protobuf_generate_c(DHT_PROTO_SRCS DHT_PROTO_HDRS dir/dht.proto)
math(EXPR PFT_EXPR "1 << 12")
set(PFT_SIZE ${PFT_EXPR} CACHE STRING
@@ -57,7 +57,7 @@ set(SOURCE_FILES
)
add_executable(ipcpd-unicast ${SOURCE_FILES} ${IPCP_SOURCES} ${COMMON_SOURCES}
- ${KAD_PROTO_SRCS} ${LAYER_CONFIG_PROTO_SRCS})
+ ${DHT_PROTO_SRCS} ${LAYER_CONFIG_PROTO_SRCS})
target_link_libraries(ipcpd-unicast LINK_PUBLIC ouroboros-dev)
include(AddCompileFlags)