summaryrefslogtreecommitdiff
path: root/src/ipcpd/raptor/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2021-03-26 12:32:06 +0100
committerSander Vrijders <sander@ouroboros.rocks>2021-03-28 12:46:05 +0200
commit994465e34a732db3bce542ee021674473f32d572 (patch)
treeec8c6f0bead35c28019da5690e11306de0e3671d /src/ipcpd/raptor/CMakeLists.txt
parent14d20740bb1c842c1b548dfec752557f5f8f58ab (diff)
downloadouroboros-994465e34a732db3bce542ee021674473f32d572.tar.gz
ouroboros-994465e34a732db3bce542ee021674473f32d572.zip
build: Remove raptor IPCP
This removes the raptor IPCP. The code hasn't been updated for a while, and wouldn't compile. Raptor served its purpose as a PoC for Ouroboros-over-Ethernet-Layer-1, but giving the extreme niche hardware needed to run it, it's not worth maintaining this anymore. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/ipcpd/raptor/CMakeLists.txt')
-rw-r--r--src/ipcpd/raptor/CMakeLists.txt50
1 files changed, 0 insertions, 50 deletions
diff --git a/src/ipcpd/raptor/CMakeLists.txt b/src/ipcpd/raptor/CMakeLists.txt
deleted file mode 100644
index 1883d9bb..00000000
--- a/src/ipcpd/raptor/CMakeLists.txt
+++ /dev/null
@@ -1,50 +0,0 @@
-get_filename_component(CURRENT_SOURCE_PARENT_DIR
- ${CMAKE_CURRENT_SOURCE_DIR} DIRECTORY)
-get_filename_component(CURRENT_BINARY_PARENT_DIR
- ${CMAKE_CURRENT_BINARY_DIR} DIRECTORY)
-
-include_directories(${CMAKE_CURRENT_SOURCE_DIR})
-include_directories(${CMAKE_CURRENT_BINARY_DIR})
-
-include_directories(${CURRENT_SOURCE_PARENT_DIR})
-include_directories(${CURRENT_BINARY_PARENT_DIR})
-
-include_directories(${CMAKE_SOURCE_DIR}/include)
-include_directories(${CMAKE_BINARY_DIR}/include)
-
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
- find_path(RAPTOR_KERNEL_MODULE
- NAMES
- raptor.ko.gz
- raptor.ko.xz
- HINTS
- /lib/modules/${CMAKE_SYSTEM_VERSION}/extra
- )
-
- mark_as_advanced(RAPTOR_KERNEL_MODULE)
-
- if (RAPTOR_KERNEL_MODULE)
- set(DISABLE_RAPTOR FALSE CACHE BOOL
- "Disable support for raptor devices")
- if (NOT DISABLE_RAPTOR)
- message(STATUS "Kernel module for raptor found. Building raptor.")
- set(IPCP_RAPTOR_TARGET ipcpd-raptor CACHE INTERNAL "")
-
- set(RAPTOR_SOURCES
- # Add source files here
- ${CMAKE_CURRENT_SOURCE_DIR}/main.c)
-
- add_executable(ipcpd-raptor ${RAPTOR_SOURCES} ${IPCP_SOURCES})
- target_link_libraries(ipcpd-raptor LINK_PUBLIC ouroboros-dev)
-
- include(AddCompileFlags)
- if (CMAKE_BUILD_TYPE MATCHES "Debug*")
- add_compile_flags(ipcpd-raptor -DCONFIG_OUROBOROS_DEBUG)
- endif ()
-
- install(TARGETS ipcpd-raptor RUNTIME DESTINATION ${CMAKE_INSTALL_SBINDIR})
- else ()
- message(STATUS "Raptor support disabled by user")
- endif ()
- endif ()
-endif ()