summaryrefslogtreecommitdiff
path: root/src/ipcpd/eth/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2019-03-20 18:33:47 +0100
committerSander Vrijders <sander@ouroboros.rocks>2019-03-21 09:42:34 +0100
commit086cd5dae628556ffaa2c2efe559a5bd2fba8d0e (patch)
tree283abbcacdacd89ace7eae9d66ec9427e69f3666 /src/ipcpd/eth/CMakeLists.txt
parentbb724cad016fba5775e751c817df0a07136d223f (diff)
downloadouroboros-086cd5dae628556ffaa2c2efe559a5bd2fba8d0e.tar.gz
ouroboros-086cd5dae628556ffaa2c2efe559a5bd2fba8d0e.zip
ipcpd: Restrict MTU for Ethernet over loopback
This restricts the MTU for the Ethernet IPCP over loopback adapters (devices named "lo*") to avoid it allocating 65K buffers per packet and quickly filling the default RDRBUFF space. The restriction is set using the build option IPCP_ETH_LO_MTU, with a default value of 1500 bytes. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/ipcpd/eth/CMakeLists.txt')
-rw-r--r--src/ipcpd/eth/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipcpd/eth/CMakeLists.txt b/src/ipcpd/eth/CMakeLists.txt
index abffbb2d..89575b6b 100644
--- a/src/ipcpd/eth/CMakeLists.txt
+++ b/src/ipcpd/eth/CMakeLists.txt
@@ -84,6 +84,8 @@ if (HAVE_ETH)
"Number of writer threads in Ethernet IPCP")
set(IPCP_ETH_QDISC_BYPASS false CACHE BOOL
"Bypass the Qdisc in the kernel when using raw sockets")
+ set(IPCP_ETH_LO_MTU 1500 CACHE STRING
+ "Restrict Ethernet MTU over loopback interfaces")
set(ETH_LLC_SOURCES
# Add source files here