summaryrefslogtreecommitdiff
path: root/src/ipcpd/eth/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri@ouroboros.rocks>2019-03-21 12:15:45 +0100
committerSander Vrijders <sander@ouroboros.rocks>2019-03-21 12:33:54 +0100
commitd6bd976b2456104a56f039ee5c5b83e82a5daa77 (patch)
tree384d4cc4a95eb0b63489a53fe8f646399b5e790d /src/ipcpd/eth/CMakeLists.txt
parent0164e81987eab940e5374b026a38a18ea94c53f9 (diff)
downloadouroboros-0.15.2.tar.gz
ouroboros-0.15.2.zip
build: Set specific compiler flags for SWIG target0.15.2
The compiler flags for the SWIG target were added to the global CMAKE_C_FLAGS used for the entire project. This sets the flags uniquely for the SWIG target. The eth has a similar case for the c99 flag. There was a lingering include in dev.c that was removed. Signed-off-by: Dimitri Staessens <dimitri@ouroboros.rocks> Signed-off-by: Sander Vrijders <sander@ouroboros.rocks>
Diffstat (limited to 'src/ipcpd/eth/CMakeLists.txt')
-rw-r--r--src/ipcpd/eth/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/ipcpd/eth/CMakeLists.txt b/src/ipcpd/eth/CMakeLists.txt
index 89575b6b..d7105b4f 100644
--- a/src/ipcpd/eth/CMakeLists.txt
+++ b/src/ipcpd/eth/CMakeLists.txt
@@ -66,7 +66,6 @@ if (NOT HAVE_RAW_SOCKETS AND NOT HAVE_BPF AND NETMAP_C_INCLUDE_DIR)
"Disable netmap support for ETH IPCPs")
if (NOT DISABLE_NETMAP)
message(STATUS "Netmap support for Ethernet IPCPs enabled")
- test_and_set_c_compiler_flag_global(-std=c99)
set(HAVE_NETMAP TRUE PARENT_SCOPE)
set(HAVE_ETH TRUE)
else ()
@@ -109,6 +108,10 @@ if (HAVE_ETH)
endif ()
if (HAVE_NETMAP AND NOT APPLE)
+ set_target_properties(ipcpd-eth-llc PROPERTIES
+ COMPILE_FLAGS "${CMAKE_C_FLAGS} -std=c99")
+ set_target_properties(ipcpd-eth-dix PROPERTIES
+ COMPILE_FLAGS "${CMAKE_C_FLAGS} -std=c99")
target_include_directories(ipcpd-eth-llc PUBLIC
${NETMAP_C_INCLUDE_DIR})
target_include_directories(ipcpd-eth-dix PUBLIC