summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-07 15:13:34 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-07 15:13:34 +0100
commitf9c16675dc625c124345bb440aa9604af61ddb8d (patch)
treeada38ded21f6e7e2a93f7047ee78bcc309da1011 /src/ipcpd/CMakeLists.txt
parent486b601ecb6d79c90eadc4dda0981e25e6a7ba1d (diff)
downloadouroboros-f9c16675dc625c124345bb440aa9604af61ddb8d.tar.gz
ouroboros-f9c16675dc625c124345bb440aa9604af61ddb8d.zip
build: Add check target, fix packaging
This adds a build target 'check', which executes a test suite for every daemon/library. Every test suite consists of a test driver that executes a function in a file with the same name as the function. The compile_debug script executes the 'check' target to validate there are no regressions. Packaging is also fixed and the prototype can be shipped as a tarball.
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index 8aec4a97..df6ba5e1 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -19,4 +19,7 @@ if (CMAKE_BUILD_TYPE MATCHES Debug)
MACRO_ADD_COMPILE_FLAGS(ipcpd -DCONFIG_OUROBOROS_DEBUG)
endif (CMAKE_BUILD_TYPE MATCHES Debug)
-install(TARGETS ipcpd RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR})
+install(TARGETS ipcpd RUNTIME DESTINATION bin)
+
+# Enable once ipcpd has tests
+# add_subdirectory(tests)