summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-05-28 19:00:30 +0200
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-05-28 19:11:39 +0200
commit97c1341690d998ef8d24abec5b83d6b03e312e0d (patch)
tree9416848007e9d554cd120871dda1c91cdc4958f2 /src/ipcpd/CMakeLists.txt
parentc510fb625427a9329668f83ca115645fa1a36091 (diff)
downloadouroboros-97c1341690d998ef8d24abec5b83d6b03e312e0d.tar.gz
ouroboros-97c1341690d998ef8d24abec5b83d6b03e312e0d.zip
ipcpd: IPCP over local memory
This introduces an IPC process that relays data between two local AP's over the shm_du_map. Only configuration it has is a DIF name. It required small modification elsewhere: lib: added support for the IPCP_LOCAL type irm: added support for the IPCP_LOCAL type dif_config: added the IPCP_LOCAL type tools: added support for the IPCP_LOCAL type
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index 5a924ffe..2758a79a 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -5,5 +5,6 @@ set(IPCP_SOURCES
${CMAKE_CURRENT_SOURCE_DIR}/ipcp-data.c
)
+add_subdirectory(local)
add_subdirectory(normal)
add_subdirectory(shim-udp)