summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2018-05-03 17:49:03 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2018-05-03 17:56:11 +0200
commit919349fd119bff11e9d34da09a9d71bf5675dba2 (patch)
treeb078ee0d0c2e5123fd1649a172d6471c3b2f9212 /src/ipcpd/CMakeLists.txt
parent8295c3628f70c1db342860ff1e79fc7056557739 (diff)
downloadouroboros-919349fd119bff11e9d34da09a9d71bf5675dba2.tar.gz
ouroboros-919349fd119bff11e9d34da09a9d71bf5675dba2.zip
ipcpd: Allow wait for dir enrollment on dt conn
This adds the option to wait for the directory (DHT) to enroll on creating a new data transfer connection. This makes scripting network bootstraps more stable. The default setting is OFF. Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index 6679ab50..5402dc80 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -14,6 +14,8 @@ set(IPCP_SCHED_THR_MUL 2 CACHE STRING
"Number of scheduler threads per QoS cube")
set(DISABLE_CORE_LOCK FALSE CACHE BOOL
"Disable locking performance threads to a core")
+set(IPCP_CONN_WAIT_DIR FALSE CACHE BOOL
+ "Check the running state of the directory when adding a dt connection")
if ((IPCP_QOS_CUBE_BE_PRIO LESS 0) OR (IPCP_QOS_CUBE_BE_PRIO GREATER 99))
message(FATAL_ERROR "Invalid priority for best effort QoS cube")