summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander D'hoore <dhoore.alexander@gmail.com>2017-12-13 17:36:32 +0100
committerSander Vrijders <sander.vrijders@ugent.be>2017-12-15 15:35:37 +0100
commit7f077e978738c3ecdb37b3d5cf30e03bb63fc8ad (patch)
tree930561ea55bfeb31d7767a2f5e16166b19e1d8a7 /src/ipcpd/CMakeLists.txt
parent0d8946ad80c5adb9a0ce76d848712af78f5910da (diff)
downloadouroboros-7f077e978738c3ecdb37b3d5cf30e03bb63fc8ad.tar.gz
ouroboros-7f077e978738c3ecdb37b3d5cf30e03bb63fc8ad.zip
ipcpd: Add support for raptor FPGA device
This adds the initial raptor support from the master thesis entitled (dutch) "Implementatie van de Recursive Internet Architecture op een FPGA platform". Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index a1559b4d..f43dba65 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -33,6 +33,7 @@ set(IPCP_SOURCES
add_subdirectory(local)
add_subdirectory(normal)
+add_subdirectory(raptor)
add_subdirectory(shim-udp)
add_subdirectory(shim-eth-llc)