summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@ugent.be>2017-08-17 14:02:34 +0200
committerdimitri staessens <dimitri.staessens@ugent.be>2017-08-17 16:10:03 +0200
commit7ae3d85c7249b9e8846bc87fdf44e8621a370565 (patch)
tree89a861ef5dd33a2055650347beddfb4ca39a9a35 /src/ipcpd/CMakeLists.txt
parentaa3416215e980a2ec87ac259be0ea39f1caf96df (diff)
downloadouroboros-7ae3d85c7249b9e8846bc87fdf44e8621a370565.tar.gz
ouroboros-7ae3d85c7249b9e8846bc87fdf44e8621a370565.zip
ipcpd: Support Berkeley Packet Filter in LLC shim
This adds support reading Ethernet frames using the Berkeley Packet Filter (BPF). Ouroboros now fully runs on OS X Sierra.
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index 2e8bda23..0ead1fed 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -8,7 +8,7 @@ set(IPCP_SOURCES
add_subdirectory(local)
add_subdirectory(normal)
add_subdirectory(shim-udp)
-if (NOT APPLE AND NOT CMAKE_SYSTEM_NAME STREQUAL GNU)
- add_subdirectory(shim-eth-llc)
+add_subdirectory(shim-eth-llc)
+if (NOT APPLE)
add_subdirectory(tests)
endif ()