summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-22 17:34:21 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-02-22 17:34:21 +0100
commit59c9251f3584e8d016c41305ec272bfbf662405a (patch)
treefcac980032d9c414ae086756f3dd7b94d1a7cc55 /src/ipcpd/CMakeLists.txt
parent815d2d611edec929b970868ac5ae9b3980165d0e (diff)
downloadouroboros-59c9251f3584e8d016c41305ec272bfbf662405a.tar.gz
ouroboros-59c9251f3584e8d016c41305ec272bfbf662405a.zip
src: Rename daemons and add tools folder
This renames the daemons to end with a 'd', as is common for UNIX daemons. It also adds a tools folder, that will hold the tools of the Ouroboros prototype. Examples are a simple echo application, an application to instruct the IRM ...
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
new file mode 100644
index 00000000..b16413cc
--- /dev/null
+++ b/src/ipcpd/CMakeLists.txt
@@ -0,0 +1,16 @@
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
+
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
+set(SOURCE_FILES
+ # Add source files here
+ main.c
+)
+
+add_executable (ipcpd ${SOURCE_FILES})
+
+target_link_libraries (ipcpd LINK_PUBLIC ouroboros)
+
+install(TARGETS ipcpd RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_BINDIR})