summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2018-04-02 08:19:54 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2018-04-05 10:31:52 +0200
commit3b03c4b2bcbcf5a913a3127d2b45283540c505c3 (patch)
treefc18ab41a741f7d6ce3b05145558a1cf83c422f8 /src/ipcpd/CMakeLists.txt
parentb81d5a327d272db9b511217665b5febceccb725d (diff)
downloadouroboros-3b03c4b2bcbcf5a913a3127d2b45283540c505c3.tar.gz
ouroboros-3b03c4b2bcbcf5a913a3127d2b45283540c505c3.zip
ipcpd: Enable locking threads to a CPU core
This adds a function that locks a thread to a random core. This greatly improves performance on multi-cpu systems. There is no portable way to do this, this only implements it for GNU/Linux. Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index d717d14a..6679ab50 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -12,6 +12,8 @@ set(IPCP_ADD_THREADS 4 CACHE STRING
"Number of extra threads to start when an IPCP faces thread starvation")
set(IPCP_SCHED_THR_MUL 2 CACHE STRING
"Number of scheduler threads per QoS cube")
+set(DISABLE_CORE_LOCK FALSE CACHE BOOL
+ "Disable locking performance threads to a core")
if ((IPCP_QOS_CUBE_BE_PRIO LESS 0) OR (IPCP_QOS_CUBE_BE_PRIO GREATER 99))
message(FATAL_ERROR "Invalid priority for best effort QoS cube")