summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@ugent.be>2018-10-18 19:53:24 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2018-10-18 20:08:20 +0200
commit0dbfdabb2f6c3ad907421f90f90714315959339f (patch)
treee406de82e92fb4e53693ce30bf54f57a36e6c86e /src/ipcpd/CMakeLists.txt
parent8b457e304186c8512139018fcdebc1c221d22ef0 (diff)
downloadouroboros-0dbfdabb2f6c3ad907421f90f90714315959339f.tar.gz
ouroboros-0dbfdabb2f6c3ad907421f90f90714315959339f.zip
ipcpd, irmd: Handle signal in main thread
The signals are now handled in the main thread instead of an asynchronous signal handler. The acceptloop is now correctly cancelled and the associated timeouts are removed. Signed-off-by: Dimitri Staessens <dimitri.staessens@ugent.be> Signed-off-by: Sander Vrijders <sander.vrijders@ugent.be>
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index 3fa3bb0f..1c6f6ae9 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -1,5 +1,3 @@
-set(IPCP_ACCEPT_TIMEOUT 100 CACHE STRING
- "Timeout for accept in IPCP mainloop threads (ms)")
set(IPCP_QOS_CUBE_BE_PRIO 50 CACHE STRING
"Priority for best effort QoS cube (0-99)")
set(IPCP_QOS_CUBE_VIDEO_PRIO 90 CACHE STRING