summaryrefslogtreecommitdiff
path: root/src/ipcpd/CMakeLists.txt
diff options
context:
space:
mode:
authordimitri staessens <dimitri.staessens@intec.ugent.be>2016-11-24 19:25:53 +0100
committerdimitri staessens <dimitri.staessens@intec.ugent.be>2016-11-25 15:20:39 +0100
commit0c2a5d4cfc662cffc76f6e9ff5ade301696ada92 (patch)
tree4ba4d14a67f8b73facd0d5b116f1c6a9b742d2a0 /src/ipcpd/CMakeLists.txt
parent1475be46f1a2eba8d14b434a0a4bdddd9295f6f4 (diff)
downloadouroboros-0c2a5d4cfc662cffc76f6e9ff5ade301696ada92.tar.gz
ouroboros-0c2a5d4cfc662cffc76f6e9ff5ade301696ada92.zip
ipcpd: Add timerwheel
The timerwheel can be used to defer work to a certain timeslot in the future.
Diffstat (limited to 'src/ipcpd/CMakeLists.txt')
-rw-r--r--src/ipcpd/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ipcpd/CMakeLists.txt b/src/ipcpd/CMakeLists.txt
index 43af7a25..afce9441 100644
--- a/src/ipcpd/CMakeLists.txt
+++ b/src/ipcpd/CMakeLists.txt
@@ -2,6 +2,7 @@ set(IPCP_SOURCES
# Add source files here
${CMAKE_CURRENT_SOURCE_DIR}/ipcp.c
${CMAKE_CURRENT_SOURCE_DIR}/ipcp-data.c
+ ${CMAKE_CURRENT_SOURCE_DIR}/timerwheel.c
)
add_subdirectory(local)
@@ -10,3 +11,4 @@ add_subdirectory(shim-udp)
if(NOT APPLE)
add_subdirectory(shim-eth-llc)
endif()
+add_subdirectory(tests)