summaryrefslogtreecommitdiff
path: root/include/ouroboros/wrap/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-09-01 17:47:30 +0200
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-09-01 17:47:30 +0200
commitb83f7683c9efb6feff98ee3a2a2f97c65dafc213 (patch)
treeed8c5e114b46ccd1fc596d8dc5f7da578ebf09a9 /include/ouroboros/wrap/CMakeLists.txt
parentfe197a226c0a7755f19a2956294ba435701a42ea (diff)
downloadouroboros-b83f7683c9efb6feff98ee3a2a2f97c65dafc213.tar.gz
ouroboros-b83f7683c9efb6feff98ee3a2a2f97c65dafc213.zip
build: Add correct include directory for swig
The correct include directory was not added to the CMakeLists in the wrap directory. Before it was working since the headers were already installed system-wide on my own system.
Diffstat (limited to 'include/ouroboros/wrap/CMakeLists.txt')
-rw-r--r--include/ouroboros/wrap/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/ouroboros/wrap/CMakeLists.txt b/include/ouroboros/wrap/CMakeLists.txt
index 39737bbc..16c86611 100644
--- a/include/ouroboros/wrap/CMakeLists.txt
+++ b/include/ouroboros/wrap/CMakeLists.txt
@@ -1,5 +1,8 @@
find_package(SWIG)
+include_directories(${CMAKE_SOURCE_DIR}/include)
+include_directories(${CMAKE_BINARY_DIR}/include)
+
if (NOT SWIG_FOUND)
message("-- SWIG not found: Bindings for other languages disabled.")
else ()