summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@ugent.be>2017-04-24 16:47:50 +0200
committerSander Vrijders <sander.vrijders@ugent.be>2017-04-24 16:47:50 +0200
commitfbf20bff013e4ca36ed7417376954723651f0a6f (patch)
treeec99c0417dd9a341d5333b990b85a50539f661b6 /include/ouroboros/CMakeLists.txt
parent1bca9a9848dc842e2a40c666560391cdd4c95ca0 (diff)
downloadouroboros-fbf20bff013e4ca36ed7417376954723651f0a6f.tar.gz
ouroboros-fbf20bff013e4ca36ed7417376954723651f0a6f.zip
lib: Remove dependency on installed headers
The header ipcp.h was not installed systemwide, giving compile time errors when trying to compile external programs that use irm.h. ipcp.h also included hash.h, which exposes project interal functions. The enum was moved to ipcp.h to prevent this.
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index b07568e3..f582b915 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -10,6 +10,7 @@ set(HEADER_FILES
errno.h
fcntl.h
fqueue.h
+ ipcp.h
irm.h
nsm.h
qos.h)