summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
authorSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-07 15:13:34 +0100
committerSander Vrijders <sander.vrijders@intec.ugent.be>2016-03-07 15:13:34 +0100
commitf9c16675dc625c124345bb440aa9604af61ddb8d (patch)
treeada38ded21f6e7e2a93f7047ee78bcc309da1011 /include/ouroboros/CMakeLists.txt
parent486b601ecb6d79c90eadc4dda0981e25e6a7ba1d (diff)
downloadouroboros-f9c16675dc625c124345bb440aa9604af61ddb8d.tar.gz
ouroboros-f9c16675dc625c124345bb440aa9604af61ddb8d.zip
build: Add check target, fix packaging
This adds a build target 'check', which executes a test suite for every daemon/library. Every test suite consists of a test driver that executes a function in a file with the same name as the function. The compile_debug script executes the 'check' target to validate there are no regressions. Packaging is also fixed and the prototype can be shipped as a tarball.
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt18
1 files changed, 14 insertions, 4 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index b4f04cf2..dc827fbe 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -1,6 +1,16 @@
-file(GLOB_RECURSE HEADER_FILES *.h)
+set(HEADER_FILES
+ bitmap.h
+ cdap.h
+ common.h
+ da.h
+ dev.h
+ du_buff.h
+ ipcp.h
+ irm.h
+ list.h
+ logs.h
+ sockets.h
+)
install(FILES ${HEADER_FILES}
- DESTINATION ${CMAKE_INSTALL_FULL_INCLUDEDIR}/ouroboros)
-
-add_custom_target(qtcreator-workaround SOURCES ${HEADER_FILES})
+ DESTINATION include/ouroboros)