summaryrefslogtreecommitdiff
path: root/include/ouroboros/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-19 13:40:03 +0100
committerDimitri Staessens <dimitri.staessens@intec.ugent.be>2016-03-19 13:53:52 +0100
commit7712e3ea9fc6772b47f593acbe3088cae01c16d2 (patch)
tree3e0962e8f7bc3957251bbe17ab418c5ebbda555b /include/ouroboros/CMakeLists.txt
parent8d2ac4877bb14df8e10d13b61d5db6c5e11d87c3 (diff)
downloadouroboros-7712e3ea9fc6772b47f593acbe3088cae01c16d2.tar.gz
ouroboros-7712e3ea9fc6772b47f593acbe3088cae01c16d2.zip
lib: shared memory map
The shared memory map will allow passing SDU's between IPCPs efficiently. It is a single block of managed memory. SDU's are stored in a shm_du_buff datastructure, which is a list of blocks inside the shared memory region. The mechanism for passing SDU's is not yet implemented and could be either within the region or using another local IPC mechanism. The following things are configured at compile time: SHM_FILE_NAME : the name. Default is "ouroboros_du_map". SHM_DU_BUFF_BLOCK_SIZE: size of a block inside the shared memory region. Default is the pagesize of the system. SHM_DU_MAP_SIZE : the approximate size in bytes of the shared memory map. The actual filesize may differ by a small margin. Default is 4MB.
Diffstat (limited to 'include/ouroboros/CMakeLists.txt')
-rw-r--r--include/ouroboros/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/include/ouroboros/CMakeLists.txt b/include/ouroboros/CMakeLists.txt
index 167cf0e2..a196140b 100644
--- a/include/ouroboros/CMakeLists.txt
+++ b/include/ouroboros/CMakeLists.txt
@@ -14,6 +14,7 @@ set(HEADER_FILES
list.h
logs.h
rina_name.h
+ shm_du_map.h
sockets.h
utils.h
)